rt-tests: add numa support for the affinity option
[pti/rtp.git] / meta-stx / recipes-rt / rt-tests / rt-tests_%.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 PACKAGECONFIG ?= "numa"
17 PACKAGECONFIG[numa] = ",,numactl,numactl"
18
19 EXTRA_OEMAKE = "\
20     ${@bb.utils.contains('PACKAGECONFIG', 'numa', 'NUMA=1', 'NUMA=0', d)} \
21     PYLIB=${libdir}/python2.7/site-packages \
22 "
23
24 FILES_${PN} += "\
25     ${libdir}/python2.7/site-packages \
26 "
27
28 RDEPENDS_${PN} += "python"