478c28dfd04cfdda14119f266eded5a6e8e868f7
[pti/rtp.git] / meta-stx / recipes-networking / vlan / vlan_2.0.5.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "ifupdown integration for vlan configuration"
17 HOMEPAGE = "https://salsa.debian.org/debian/vlan"
18 SECTION = "misc"
19 LICENSE = "GPLv2+"
20 LIC_FILES_CHKSUM = "file://debian/copyright;;md5=a99f1f04fc1d4f5d723231f8937bdc2b"
21
22 SRC_URI = "https://deb.debian.org/debian/pool/main/v/vlan/vlan_2.0.5.tar.xz"
23
24 SRC_URI[md5sum] = "e6994250748fa3ee6d99f3ac292b7eb9"
25 SRC_URI[sha256sum] = "ccf261839b79247be8dae93074e1c5fcbce3807787a0ff7aed4e1f7a9095c465"
26
27 do_install () {
28     install -d ${D}${base_sbindir}
29     install -m 0755 ${S}/vconfig ${D}${base_sbindir}/
30
31     install -d ${D}${sysconfdir}
32     cp -av --no-preserve=ownership ${S}/debian/network ${D}${sysconfdir}
33 }