Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-networking / ipset / ipset_6.38.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Manage Linux IP sets"
17 DESCRIPTION = " \
18 IP sets are a framework inside the Linux kernel since version 2.4.x, which can  \
19 be administered by the ipset utility. Depending on the type, currently an IP \
20 set may store IP addresses, (TCP/UDP) port numbers or IP addresses with MAC \
21 addresses in a way, which ensures lightning speed when matching an entry \
22 against a set. \
23 \
24 If you want to: \
25  - store multiple IP addresses or port numbers and match against the collection \
26    by iptables at one swoop; \
27  - dynamically update iptables rules against IP addresses or ports without \
28    performance penalty; \
29  - express complex IP address and ports based rulesets with one single iptables \
30    rule and benefit from the speed of IP sets \
31 then ipset may be the proper tool for you. \
32 "
33
34 HOMEPAGE = "http://ipset.netfilter.org"
35
36 LICENSE = "GPL-2.0"
37 LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
38
39 SECTION = "network"
40
41 DEPENDS = "libtool libmnl"
42
43 SRC_URI = "http://ftp.netfilter.org/pub/ipset/${BP}.tar.bz2"
44
45 SRC_URI[md5sum] = "0e5d9c85f6b78e7dff0c996e2900574b"
46 SRC_URI[sha256sum] = "ceef625ba31fe0aaa422926c7231a819de0b07644c02c17ebdd3022a29e3e244"
47
48 inherit autotools pkgconfig module-base
49
50 EXTRA_OECONF += "-with-kbuild=${KBUILD_OUTPUT} --with-ksource=${STAGING_KERNEL_DIR}"
51
52 RDEPENDS_${PN} = "kernel-module-ip-set"
53 RRECOMMENDS_${PN} = "\
54     kernel-module-ip-set-bitmap-ip \
55     kernel-module-ip-set-bitmap-ipmac \
56     kernel-module-ip-set-bitmap-port \
57     kernel-module-ip-set-hash-ip \
58     kernel-module-ip-set-hash-ipmac \
59     kernel-module-ip-set-hash-ipmark \
60     kernel-module-ip-set-hash-ipport \
61     kernel-module-ip-set-hash-ipportip \
62     kernel-module-ip-set-hash-ipportnet \
63     kernel-module-ip-set-hash-mac \
64     kernel-module-ip-set-hash-net \
65     kernel-module-ip-set-hash-netiface \
66     kernel-module-ip-set-hash-netnet \
67     kernel-module-ip-set-hash-netport \
68     kernel-module-ip-set-hash-netportnet \
69     kernel-module-ip-set-list-set \
70 "