2799dfcc04d317c29e04dfdcc63ae0838240611d
[pti/rtp.git] / meta-stx / recipes-httpd / apache2 / apache2_%.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16
17 APACHE_PORT_NUM ?= "81"
18
19 do_install_append () {
20         sed -i -e 's/80/${APACHE_PORT_NUM}/' ${D}/${sysconfdir}/${BPN}/httpd.conf
21 }
22
23 inherit useradd
24
25 USERADD_PACKAGES = "${PN}"
26
27 USERADD_PARAM_${PN} = "-c 'Apache' -u 48 -g apache -s /sbin/nologin -r -d /usr/share/httpd apache"
28 GROUPADD_PARAM_${PN} = "-g 48 -r apache"