Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-extended / sudo / sudo_%.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17
18 DEPENDS += " \
19         openldap \
20         libgcrypt \
21         "
22
23 SRC_URI += " \
24         file://sudo-1.6.7p5-strip.patch \
25         file://sudo-1.7.2p1-envdebug.patch \
26         file://sudo-1.8.23-sudoldapconfman.patch \
27         file://sudo-1.8.23-legacy-group-processing.patch \
28         file://sudo-1.8.23-ldapsearchuidfix.patch \
29         file://sudo-1.8.6p7-logsudouser.patch \
30         file://sudo-1.8.23-nowaitopt.patch \
31         file://sudo-1.8.23-fix-double-quote-parsing-for-Defaults-values.patch \
32         "
33
34 EXTRA_OECONF += " \
35         --with-pam-login \
36         --with-editor=${base_bindir}/vi \
37         --with-env-editor \
38         --with-ignore-dot \
39         --with-tty-tickets \
40         --with-ldap \
41         --with-ldap-conf-file="${sysconfdir}/sudo-ldap.conf" \
42         --with-passprompt="[sudo] password for %Zp: " \
43         --with-sssd \
44         "
45
46 do_install_append () {
47         install -m755 -d ${D}/${sysconfdir}/openldap/schema
48         install -m644 ${S}/doc/schema.OpenLDAP  ${D}/${sysconfdir}/openldap/schema/sudo.schema
49 }
50
51 # This means sudo package only owns files
52 # to avoid install conflict with openldap on
53 # /etc/openldap. Sure there is a better way.
54 DIRFILES = "1"