284b22a03c8d26cde45542338d6b6fd15d1689c8
[pti/rtp.git] / meta-stx / recipes-extended / postgresql / postgresql_%.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 COMPUTE_IP="127.0.0.1"
17 CONTROLLER_IP="127.0.0.1"
18
19 FILESEXTRAPATHS_prepend := "${THISDIR}/postgresql:"
20
21 SRC_URI += " \
22     file://postgresql.service.update \
23     "
24
25 do_install_append() {
26        install -d ${D}${systemd_unitdir}/system
27        install -m 0755 ${WORKDIR}/postgresql.service.update ${D}${systemd_unitdir}/system/postgresql.service
28 }
29
30 FILES_${PN} += "${systemd_unitdir}/system/postgresql.service"