Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-extended / lsb / lsbinitscripts_9.79.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17
18 SRC_URI += "file://service-redirect-to-restart-for-reload.patch"
19
20 DEPENDS += "\
21     gettext-native \
22     glib-2.0 \
23     popt \
24 "
25
26 unset do_configure[noexec]
27 unset do_compile[noexec]
28
29 do_install_append() {
30         install -m 0755 -d ${D}/${sysconfdir}/profile.d/
31         install -m 0644 ${S}/lang.sh  ${D}${sysconfdir}/profile.d/lang.sh
32         install -m 0755 -d ${D}/${base_sbindir}
33         install -m 0755 ${S}/src/consoletype ${D}/${base_sbindir}
34
35         install -m 0755 -d ${D}/${bindir}
36         install -m 0755 ${S}/service ${D}/${bindir}
37         sed -i -e 's|${bindir}|${base_bindir}|' ${D}/${bindir}/service
38 }
39
40 FILES_${PN}_append = "${sysconfdir}/profile.d/lang.sh"