Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-extended / ibsh / ibsh_0.3e.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "ibsh Iron Bar Shell"
17 DESCRIPTION = "CGCS add default users types"
18 SECTION = "base/shell"
19 HOMEPAGE = "https://sourceforge.net/projects/ibsh/"
20
21 LICENSE = "GPLv2+"
22 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
23                     file://COPYRIGHT;md5=e5ef2fe07fcba90ea59f9f1a61f7526b \
24 "
25
26 SRC_URI[md5sum] = "41ea08a03c6bd805dff1a5ff25ea1d5b"
27 SRC_URI[sha256sum] = "4c40d0841527c76fc75ccc27d32b575543d02d661973fc3561004efb6033206d"
28 SRC_URI = "https://downloads.sourceforge.net/project/ibsh/ibsh/ibsh-0.3e/ibsh-0.3e.tar.gz"
29
30 do_install() {
31         cd ${S}
32         install -d -m0755 ${D}/${base_bindir}
33         install -d -m0755 ${D}/${sysconfdir}/ibsh/cmds/
34         install -d -m0755 ${D}/${sysconfdir}/ibsh/xtns/
35         install -m0755 ibsh ${D}/${base_bindir}
36         install -m0644 globals.cmds ${D}/${sysconfdir}/ibsh
37         install -m0644 globals.xtns ${D}/${sysconfdir}/ibsh
38 }