collectd: add missing config files for plugins
[pti/rtp.git] / meta-stx / recipes-extended / collectd / collectd_%.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17
18 SRC_URI += " \
19     file://collectd-fix-for-LIBPYTHON_LDFLAGS.patch \
20     file://default-plugins-cpu.conf \
21     file://default-plugins-interface.conf \
22     file://default-plugins-load.conf \
23     file://default-plugins-memory.conf \
24     file://default-plugins-syslog.conf \
25     "
26
27 PACKAGECONFIG += "python"
28
29 PACKAGECONFIG[python] = "--enable-python --with-libpython,--disable-python --with-libpython=no,python"
30
31 do_install_append () {
32     install -m 755 -d ${D}${sysconfdir}/collectd.d/
33     install -m 644 ${WORKDIR}/default-plugins-cpu.conf ${D}${sysconfdir}/collectd.d/90-default-plugins-cpu.conf
34     install -m 644 ${WORKDIR}/default-plugins-interface.conf ${D}${sysconfdir}/collectd.d/90-default-plugins-interface.conf
35     install -m 644 ${WORKDIR}/default-plugins-load.conf ${D}${sysconfdir}/collectd.d/90-default-plugins-load.conf
36     install -m 644 ${WORKDIR}/default-plugins-memory.conf ${D}${sysconfdir}/collectd.d/90-default-plugins-memory.conf
37     install -m 644 ${WORKDIR}/default-plugins-syslog.conf ${D}${sysconfdir}/collectd.d/90-default-plugins-syslog.conf
38 }