Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python3-redfishtool_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Client side API implementation of the Redfish RESTful API for Data Center Hardware Management."
17 HOMEPAGE = "https://github.com/DMTF/Redfishtool"
18 SECTION = "devel/python"
19 LICENSE = "BSD-3-Clause"
20 LIC_FILES_CHKSUM = "file://LICENSE.md;md5=cee7a7694b5bf14bc9d3e0fbe78a64af"
21
22
23 SRCREV = "2bdcd905e1ad227f40809ec298804d5401047612"
24 SRCNAME = "Redfishtool"
25 BRANCH = "master"
26 PROTOCOL = "https"
27 PV = "1.1.0+git${SRCPV}"
28 S = "${WORKDIR}/git"
29
30 SRC_URI = "git://github.com/DMTF/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
31
32 inherit setuptools3
33
34 RDEPENDS_${PN} += " \
35         python3-requests \
36 "
37
38 do_install_append() {
39         :
40 }
41
42 FILES_${PN} += " \
43         "