Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python3-pymysql_0.9.3.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "A pure-Python MySQL client library"
17 DESCRIPTION = " \
18 This package contains a pure-Python MySQL client library, based on PEP 249 \
19 Most public APIs are compatible with mysqlclient and MySQLdb.\
20 "
21 SECTION = "devel/python"
22 HOMEPAGE = "https://github.com/PyMySQL/PyMySQL"
23 LICENSE = "MIT"
24 LIC_FILES_CHKSUM = "file://LICENSE;md5=528175c84163bb800d23ad835c7fa0fc"
25
26 inherit pypi
27 inherit setuptools3
28
29 PYPI_PACKAGE = "PyMySQL"
30
31 SRC_URI[md5sum] = "e5d9183cc0a775ac29f9e0365cca6556"
32 SRC_URI[sha256sum] = "d8c059dcd81dedb85a9f034d5e22dcb4442c0b201908bede99e306d65ea7c8e7"