Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python3-pecan_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "WSGI object-dispatching web framework"
17
18 HOMEPAGE = "https://pypi.python.org/pypi/pecan/"
19 SECTION = "devel/python"
20 LICENSE = "BSD"
21 LIC_FILES_CHKSUM = "file://LICENSE;md5=d846877d24bbb3d7a00a985c90378e8c"
22
23 SRCREV = "da15e06d783e2cf569b39ba506e68e4e1e85568d"
24 PROTOCOL = "https"
25 BRANCH = "master"
26 S = "${WORKDIR}/git"
27
28 SRC_URI = "git://github.com/pecan/pecan.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
29
30
31 inherit setuptools3 distutils3
32
33 RDEPENDS_${PN} = "python3-mako \
34                   python3-six \
35                   python3-logutils \
36                   python3-webtest  \
37                   "
38
39 do_install_append() {
40         mv ${D}/${bindir}/gunicorn_pecan ${D}/${bindir}/gunicorn_pecan3
41         mv ${D}/${bindir}/pecan ${D}/${bindir}/pecan3
42 }