Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python3-cheroot_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Cheroot is the high-performance, pure-Python HTTP server used by CherryPy."
17
18 LICENSE = "BSD-3-Clause"
19 LIC_FILES_CHKSUM = "file://LICENSE.md;md5=beeffd9dfcc746ed5a91921f1acc2746"
20
21 SRCREV = "c7ca7ff0bcebb53e1bed783280a3bb5db35f900f"
22 PROTOCOL = "https"
23 BRANCH = "master"
24 S = "${WORKDIR}/git"
25 PV = "7.0.0"
26
27 SRC_URI = "git://github.com/cherrypy/cheroot.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
28
29
30 DEPENDS += " \
31         python3 \
32         python3-setuptools-scm-native \
33         python3-setuptools-scm-git-archive-native \
34         "
35
36 RDEPENDS_${PN} += " \
37         python3-email \
38         python3-fcntl \
39         python3-io \
40         python3-logging \
41         python3-unixadmin \
42         python3-pyopenssl \
43         python3-six \
44         "
45
46 inherit setuptools3 distutils3 pkgconfig