Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-zipp_0.6.0.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Backport of pathlib-compatible object wrapper for zip files"
17 HOMEPAGE = "https://github.com/jaraco/zipp"
18 LICENSE = "MIT"
19 LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
20
21 SRC_URI[md5sum] = "d4451a749d8a7c3c392a9edd1864a937"
22 SRC_URI[sha256sum] = "3718b1cbcd963c7d4c5511a8240812904164b7f381b647143a89d3b98f9bcd8e"
23
24 DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
25 RDEPENDS_${PN} += "${PYTHON_PN}-more-itertools"
26
27 inherit pypi setuptools
28
29 BBCLASSEXTEND = "native nativesdk"