Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-snowballstemmer_2.0.0.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = " \
17         Snowball is a small string processing language designed for creating stemming algorithms \
18         for use in Information Retrieval. This site describes Snowball, and presents several useful \
19         stemmers which have been implemented using it. \
20         "
21 HOMEPAGE = "https://github.com/snowballstem/snowball"
22 SECTION = "devel/python"
23 LICENSE = "BSD-3-Clause"
24 LIC_FILES_CHKSUM = "file://COPYING;md5=2750797da77c1d784e7626b3f7d7ff3e"
25
26 SRC_URI[md5sum] = "c05ec4a897be3c953c8b8b844c4241d4"
27 SRC_URI[sha256sum] = "df3bac3df4c2c01363f3dd2cfa78cce2840a79b9f1c2d2de9ce8d31683992f52"
28
29 PYPI_PACKAGE = "snowballstemmer"
30 inherit setuptools pypi