Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-ryu_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Ryu is a component-based software defined networking framework."
17 HOMEPAGE = "https://github.com/osrg/ryu"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = " \
21         file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57\
22         "
23
24 SRCREV = "1c008060fa3dab51c3a59c1485a7529b13cf0dd1"
25 SRCNAME = "ryu"
26 BRANCH = "master"
27 PROTOCOL = "https"
28 PV = "4.24+git${SRCPV}"
29 S = "${WORKDIR}/git"
30
31 SRC_URI = "git://github.com/osrg/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
32
33 inherit setuptools python-dir
34
35 DEPENDS += " \
36         python-pip \
37         python-pbr-native \
38         "
39
40 RDEPENDS_${PN}_append = " \
41         ${PYTHON_PN}-eventlet \
42         ${PYTHON_PN}-msgpack \
43         ${PYTHON_PN}-netaddr \
44         ${PYTHON_PN}-oslo.config \
45         ${PYTHON_PN}-ovs \
46         ${PYTHON_PN}-routes \
47         ${PYTHON_PN}-six \
48         ${PYTHON_PN}-tinyrpc \
49         ${PYTHON_PN}-webob \
50         "
51
52 FILES_${PN}_append = " \
53         ${datadir}/etc/${SRCNAME} \
54         "