Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-requests-toolbelt_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "requests-toolbelt"
17
18 STABLE = "master"
19 PROTOCOL = "https"
20 BRANCH = "master"
21 SRCREV = "1e384626476f7afbff0f649fe41886d0f27473d6"
22 S = "${WORKDIR}/git"
23 PV = "0.9.1+${SRCPV}"
24
25 LICENSE = "Apache-2.0"
26
27 LIC_FILES_CHKSUM = "file://LICENSE;md5=71760e0f1dda8cff91b0bc9246caf571"
28
29 SRC_URI = "git://github.com/requests/toolbelt.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31 DEPENDS = " \
32         python \
33         python-pbr-native \
34         "
35
36 inherit setuptools
37
38 RDEPENDS_${PN} += " bash"