Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-pysaml2_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Python implementation of SAML Version 2 to be used in a WSGI environment"
17 HOMEPAGE = "https://github.com/rohe/pysaml2"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=861cc9087857b5bea2e11356c3de95d9"
21
22 SRCREV = "c740a3a270037d6fcb42a12112db594705d3878f"
23 SRCNAME = "pysaml2"
24 PROTOCOL = "git"
25 BRANCH = "v4.9.0"
26 S = "${WORKDIR}/git"
27 PV = "4.5.0+git${SRCPV}"
28
29 SRC_URI = "git://github.com/rohe/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31 inherit setuptools
32
33 DEPENDS += " \
34         python-pip \
35         "
36
37 RDEPENDS_${PN} += " \
38         python-zopeinterface \
39         python-repoze.who \
40         python-defusedxml \
41         "