python-pyliblzma: add new recipe
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-pyliblzma_0.5.3.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Python bindings for liblzma"
17 DESCRIPTION = "\
18 PylibLZMA provides a python interface for the liblzma library to read and write data \
19 that has been compressed or can be decompressed by Lasse Collin’s xz / lzma utils. \
20 "
21 LICENSE = "LGPLv3"
22 LIC_FILES_CHKSUM = "file://COPYING;md5=58c39b26c0549f8e1bb4122173f474cd"
23
24 SRC_URI[md5sum] = "500f61116ee1ab4063b49c121786863a"
25 SRC_URI[sha256sum] = "08d762f36d5e59fb9bb0e22e000c300b21f97e35b713321ee504cfb442667957"
26
27 DEPENDS = "xz"
28
29 inherit pypi setuptools
30
31 PYPI_PACKAGE = "pyliblzma"
32 PYPI_PACKAGE_EXT = "tar.bz2"
33
34 BBCLASSEXTEND = " native"