Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-pycurl_7.43.0.3.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "libcurl python bindings"
17 LICENSE = "LGPLv2 | MIT"
18 LIC_FILES_CHKSUM = " \
19         file://COPYING-LGPL;md5=4fbd65380cdd255951079008b364516c \
20         file://COPYING-MIT;md5=2df767ed35d8ea83de4a93feb55e7815 \
21         "
22
23 SRC_URI[sha256sum] = "6f08330c5cf79fa8ef68b9912b9901db7ffd34b63e225dce74db56bb21deda8e"
24
25
26 PYPI_PACKAGE = "pycurl"
27 inherit pypi setuptools
28
29 export BUILD_SYS
30 export HOST_SYS
31 export STAGING_INCDIR
32 export STAGING_LIBDIR
33
34 DEPENDS = " curl python"
35
36 BBCLASSEXTEND = " native"