Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-packaging_20.1.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = " \
17         Core utilities for Python packages. \
18         The packaging project includes the following: version handling, specifiers, markers, requirements, tags, utilities. \
19         "
20 HOMEPAGE = "https://github.com/pypa/packaging"
21 SECTION = "devel/python"
22 LICENSE = "BSD"
23 LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
24
25 SRC_URI[md5sum] = "a02ce566f10c701b4c42e39a4ce59c93"
26 SRC_URI[sha256sum] = "e665345f9eef0c621aa0bf2f8d78cf6d21904eef16a93f020240b704a57f1334"
27
28 PYPI_PACKAGE = "packaging"
29 inherit setuptools pypi