Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-osprofiler_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Library for cross-project profiling library"
17 HOMEPAGE = "https://docs.openstack.org/osprofiler/latest/"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=19cbd64715b51267a47bf3750cc6a8a5"
21
22 SRCREV = "6d68170f72ef303e6564e164aafb1ec53a8b8314"
23 SRCNAME = "osprofiler"
24 BRANCH = "master"
25 PROTOCOL = "https"
26 PV = "2.3.0+git${SRCPV}"
27 S = "${WORKDIR}/git"
28
29 SRC_URI = "git://opendev.org/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30         
31 inherit setuptools
32
33 DEPENDS += " python-pbr-native"
34
35 RDEPENDS_${PN}_append = " \
36         python-pbr \
37         python-six \
38         python-oslo.messaging \
39         python-oslo.log \
40         python-oslo.utils \
41         python-webob \
42         python-requests \
43         python-netaddr \
44         python-oslo.concurrency \
45         "