Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-oslo.versionedobjects_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Oslo versionedobjects library"
17 HOMEPAGE = "https://wiki.openstack.org/wiki/Oslo"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
21
22 SRCREV = "c95f0c876840e36f37acb14d5eec5238d85e7dce"
23 SRCNAME = "oslo.versionedobjects"
24 PROTOCOL = "https"
25 BRANCH = "stable/queens"
26 S = "${WORKDIR}/git"
27 PV = "1.31.2+git${SRCPV}"
28
29 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31 inherit setuptools
32
33 DEPENDS += " \
34         python-pip \
35         python-pbr-native \
36         "
37
38 RDEPENDS_${PN} += " \
39         python-six \
40         python-oslo.concurrency \
41         python-oslo.config \
42         python-oslo.context \
43         python-oslo.messaging \
44         python-oslo.serialization \
45         python-oslo.utils \
46         python-oslo.log \
47         python-oslo.i18n \
48         python-webob \
49         python-iso8601 \
50         python-netaddr \
51        "