Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-oslo.upgradecheck_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Common code for writing OpenStack upgrade checks"
17 DESCRIPTION = "\
18   This project contains the common code necessary for writing upgrade checks \
19   in OpenStack projects. It includes a module (oslo_upgradecheck.upgradecheck) \
20   for the common code as well as an example (oslo_upgradecheck.__main__) of \
21   integrating that code into a project. \
22 "
23 HOMEPAGE = "https://github.com/openstack/oslo.upgradecheck"
24 SECTION = "devel/python"
25
26 LICENSE = "Apache-2.0"
27 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
28
29 PV = "0.3.1+git${SRCPV}"
30 SRCREV = "5f182fe19cdfe0bcf0d51bcf7be05e7a74f0a068"
31
32 SRCNAME = "oslo.upgradecheck"
33 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master"
34
35 S = "${WORKDIR}/git"
36
37 inherit setuptools
38
39 DEPENDS += " \
40     python-pip \
41     python-pbr-native \
42 "
43
44 RDEPENDS_${PN} += " \
45     python-oslo.config \
46     python-oslo.i18n \
47 "