Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-oslo.serialization_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Oslo Serialization API"
17 HOMEPAGE = "https://launchpad.net/oslo"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
21
22 SRCREV = "576b13ec26baa671da05df56a8d14aba6fa3e826"
23 SRCNAME = "oslo.serialization"
24 PROTOCOL = "https"
25 BRANCH = "stable/train"
26 S = "${WORKDIR}/git"
27 PV = "2.23.0+git${SRCPV}"
28
29 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31
32 inherit setuptools
33
34 # DEPENDS_default: python-pip
35
36 DEPENDS += " \
37         python-pip \
38         python-pbr-native\
39         "
40
41 # Satisfy setup.py 'setup_requires'
42 DEPENDS += " \
43         python-pbr-native \
44         "
45
46 # RDEPENDS_default:
47 RDEPENDS_${PN} += " \
48         python-pbr \
49         python-six \
50         python-oslo.utils \
51         python-pytz \
52         python-msgpack \
53         "