Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-oslo.middleware_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Oslo Middleware Library"
17 HOMEPAGE = "https://launchpad.net/oslo"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
21
22 SRCREV = "8812bc3fc490f0db4977418eaedf58190a0df394"
23 SRCNAME = "oslo.middleware"
24 PROTOCOL = "https"
25 BRANCH = "stable/train"
26 S = "${WORKDIR}/git"
27 PV = "3.31.0+git${SRCPV}"
28
29 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31 inherit setuptools
32
33 DEPENDS += " \
34         python-pip \
35         python-pbr-native \
36         "
37
38 # Satisfy setup.py 'setup_requires'
39 DEPENDS += " \
40         python-pbr-native \
41         "
42
43 # RDEPENDS_default:
44 RDEPENDS_${PN} += " \
45         python-pbr \
46         python-jinja2 \
47         python-oslo.config \
48         python-oslo.context \
49         python-oslo.i18n \
50         python-oslo.utils \
51         python-six \
52         python-stevedore \
53         python-webob \
54         python-debtcollector \
55         python-statsd \
56         "