Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-oslo.config_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "API supporting parsing command line arguments and .ini style configuration files."
17 HOMEPAGE = "https://pypi.python.org/pypi/oslo.config/5.2.0"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=c46f31914956e4579f9b488e71415ac8"
21
22 SRCREV = "31c11ab4289efa1a91835f3daa928fe927ac4276"
23 SRCNAME = "oslo.config"
24 PROTOCOL = "https"
25 BRANCH = "stable/queens"
26 S = "${WORKDIR}/git"
27 PV = "5.2.0+git${SRCPV}"
28
29 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31 inherit setuptools rmargparse
32
33 DEPENDS += " \
34         python-pbr \
35         python-pip \
36         "
37
38 # Satisfy setup.py 'setup_requires'
39 DEPENDS += " \
40         python-pbr-native \
41         "
42
43 RDEPENDS_${PN} += " \
44     python-pbr \
45     python-netaddr \
46     python-six \
47     python-stevedore \
48     python-debtcollector \
49     python-oslo.i18n \
50     python-rfc3986 \
51     python-pyyaml \
52     python-importlib-metadata \
53     "
54