Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-oslo.cache_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "oslo.config enabled dogpile cache"
17 HOMEPAGE = "https://github.com/openstack/oslo.cache"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
21
22 SRCREV = "3b8d9c3f6c87d62e5502cf4a9ae89e4067180c1f"
23 SRCNAME = "oslo.cache"
24 PROTOCOL = "https"
25 BRANCH = "stable/train"
26 S = "${WORKDIR}/git"
27 PV = "1.26.0+git${SRCPV}"
28
29 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31 inherit setuptools rmargparse
32
33 DEPENDS += " \
34         python-pbr \
35         python-pip \
36         "
37
38 DEPENDS += " \
39         python-pbr-native \
40         "
41
42 # RDEPENDS_default:
43 RDEPENDS_${PN} += " \
44         python-dogpile.cache \
45         python-six \
46         python-oslo.config \
47         python-oslo.i18n \
48         python-oslo.log \
49         python-oslo.utils \
50         "