Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-osc-lib_1.12.1.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "OpenStackClient Library"
17 HOMEPAGE = "http://opensource.perlig.de/rcssmin/"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
21
22 SRC_URI[md5sum] = "73c8bd90b8325b2595b814f41d06fdb8"
23 SRC_URI[sha256sum] = "26d3e32c8c4eff47240c458cddb6b75db52034d643f01de2841ad9e84904d7aa"
24
25 inherit setuptools pypi
26
27 # Satisfy setup.py 'setup_requires'
28 DEPENDS += " \
29         python-pbr-native \
30         "
31
32 RDEPENDS_${PN} += " \
33         python-pbr \
34         python-six \
35         python-babel \
36         python-cliff \
37         python-keystoneauth1 \
38         python-os-client-config \
39         python-oslo.i18n \
40         python-oslo.utils \
41         python-simplejson \
42         python-stevedore \
43         "
44
45 CLEANBROKEN = "1"