Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-neutronclient_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "CLI and python client library for OpenStack Neutron"
17 HOMEPAGE = "https://launchpad.net/neutron"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
21
22 SRCREV = "680b417111dbbda9e318700286c4efd9055f1af3"
23 SRCNAME = "python-neutronclient"
24 BRANCH = "stable/train"
25 PROTOCOL = "https"
26 PV = "6.12.0+git${SRCPV}"
27 S = "${WORKDIR}/git"
28
29 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30         
31 inherit setuptools monitor rmargparse
32
33 DEPENDS += " \
34         python-pip \
35         python-pbr-native\
36         "
37
38 # Satisfy setup.py 'setup_requires'
39 DEPENDS += " \
40         python-pbr-native \
41         "
42
43 RDEPENDS_${PN} += " \
44         python-pbr \
45         python-cliff \
46         python-debtcollector \
47         python-iso8601 \
48         python-netaddr \
49         python-osc-lib \
50         python-oslo.i18n \
51         python-oslo.serialization \
52         python-oslo.utils \
53         python-os-client-config \
54         python-keystoneauth1 \
55         python-keystoneclient \
56         python-requests \
57         python-simplejson \
58         python-six \
59         python-babel \
60         "
61
62
63 PACKAGECONFIG ?= "bash-completion"
64 PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"
65
66 do_install_append() {
67         install -d ${D}/${sysconfdir}/bash_completion.d
68         install -m 664 ${S}/tools/neutron.bash_completion ${D}/${sysconfdir}/bash_completion.d
69 }
70
71 PACKAGES =+ "${BPN}-bash-completion"
72 FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"
73
74 MONITOR_CHECKS_${PN} += "\
75         neutron-api-check.sh \
76 "