Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-muranoclient_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "python-muranoclient"
17 STABLE = "master"
18 PROTOCOL = "https"
19 BRANCH = "master"
20 SRCREV = "70b4392c7f8524ac25dbf3ab0feb3ac4127c1ecf"
21 S = "${WORKDIR}/git"
22 PV = "1.1.1"
23
24 LICENSE = "Apache-2.0"
25
26 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
27
28 SRC_URI = "git://github.com/openstack/python-muranoclient.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
29
30 DEPENDS += " \
31         python \
32         python-pbr-native \
33         "
34
35 inherit setuptools
36
37 RDEPENDS_${PN}_append = " \
38         bash    \
39         python-pbr \
40         python-prettytable \
41         python-glanceclient \
42         python-keystoneclient \
43         python-iso8601 \
44         python-six \
45         python-babel \
46         python-pyopenssl \
47         python-requests \
48         python-pyyaml \
49         python-yaql \
50         python-osc-lib \
51         python-murano-pkg-check \
52         python-oslo.serialization \
53         python-oslo.utils \
54         python-oslo.log \
55         python-oslo.i18n \
56         "