e73b40e13ec36251f40998e02b143cc892f0b739
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-ldap_3.2.0.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 #
17 # Copyright (C) 2012 Wind River Systems, Inc.
18 #
19 SUMMARY = "Provides a wrapper in Python to LDAP"
20 DESCRIPTION = "This module provides access to the LDAP \
21 (Lightweight Directory Access Protocol) through Python operations \
22 instead of C API. The module mainly acts as a wrapper for the \
23 OpenLDAP 2.x libraries. Errors will appear as exceptions."
24
25 LICENSE = "PSF"
26 HOMEPAGE = "http://www.python-ldap.org/"
27 DEPENDS = "python openldap cyrus-sasl"
28
29 PYPI_PACKAGE = "python-ldap"
30 inherit pypi setuptools
31
32 LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
33 SRC_URI[md5sum] = "fe22522208dc9b06d16eb70f8553eaab"
34 SRC_URI[sha256sum] = "7d1c4b15375a533564aad3d3deade789221e450052b21ebb9720fb822eccdb8e"
35
36 do_configure_prepend() {
37     sed -i -e 's:^library_dirs =.*::' setup.cfg
38     sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' setup.cfg
39 }
40
41 RDEPENDS_${PN} = " \
42     ${PYTHON_PN}-pprint \
43     ${PYTHON_PN}-threading \
44     ${PYTHON_PN}-pyasn1 \
45     ${PYTHON_PN}-pyasn1-modules \
46 "