Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-keystonemiddleware_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Middleware for Openstack identity API"
17 HOMEPAGE = "https://launchpad.net/keystonemiddleware"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55"
21
22 SRCREV = "83d0612e03471f56be3be2b521cc21974118cebe"
23 SRCNAME = "keystonemiddleware"
24 BRANCH = "stable/train"
25 PROTOCOL = "https"
26 PV = "5.1.0"
27 S = "${WORKDIR}/git"
28
29 SRC_URI = "git://git.openstack.org/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31
32 inherit setuptools
33
34 DEPENDS += " \
35         python-pip \
36         python-pbr-native \
37         "
38
39 # Satisfy setup.py 'setup_requires'
40 DEPENDS += " \
41         python-pbr-native \
42         "
43
44 RDEPENDS_${PN} += " \
45         python-keystoneauth1 \
46         python-oslo.cache \
47         python-oslo.config \
48         python-oslo.context \
49         python-oslo.i18n \
50         python-oslo.log \
51         python-oslo.serialization \
52         python-oslo.utils \
53         python-pbr \
54         python-positional \
55         python-pycadf \
56         python-keystoneclient \
57         python-requests \
58         python-six \
59         python-webob \
60         "