Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-keyring_5.3.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17
18 SRC_URI += " \
19       file://python-keyring/no_keyring_password.patch \
20       file://python-keyring/lock_keyring_file.patch \
21       file://python-keyring/lock_keyring_file2.patch \
22       file://python-keyring/use_new_lock.patch \
23       file://python-keyring/fix_keyring_lockfile_location.patch \
24       file://python-keyring/use_temporary_file.patch \
25       file://python-keyring/chown_keyringlock_file.patch \
26       file://python-keyring/chmod_keyringlock2.patch \
27       file://python-keyring/keyring_path_change.patch \
28       file://python-keyring/remove-reader-lock.patch \
29       file://python-keyring/remove_others_perms_on_keyringcfg_file.patch \
30 "
31
32 DEPENDS += " python-hgtools-native"