a62033b50e0830318397b245ce799d0fc265e693
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-jmespath_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "JMESPath (pronounced “james path”) allows you to declaratively specify how to extract elements from a JSON document."
17
18 LICENSE = "MIT"
19 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2683790f5fabb41a3f75b70558799eb4"
20
21 PV = "0.9.4"
22
23 SRCREV = "4a4f6dbd98549b2b8fc71bbc19860d317a6abfdb"
24 PROTOCOL = "https"
25 BRANCH = "master"
26 S = "${WORKDIR}/git"
27
28 SRC_URI = "git://github.com/jmespath/jmespath.py;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
29
30
31 DEPENDS += " python"
32 inherit setuptools distutils pkgconfig