Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-ironicclient_2.7.0.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "python-ironicclient"
17 STABLE = "master"
18 PROTOCOL = "https"
19 BRANCH = "master"
20 PV = "2.7.0"
21
22 LICENSE = "Apache-2.0"
23
24 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
25
26 SRC_URI = "https://tarballs.openstack.org/python-ironicclient/python-ironicclient-${PV}.tar.gz"
27 SRC_URI[md5sum] = "6b13e133eb0c521a09c377f28fef139e"
28
29 DEPENDS += " \
30         python \
31         python-pbr-native \
32         "
33
34 inherit setuptools
35
36 RDEPENDS_${PN}_append = " \
37         bash \
38         python-dogpile.cache \
39         "