Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-importlib-metadata_0.23.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Read metadata from Python packages"
17 DESCRIPTION = "Read metadata from Python packages"
18 HOMEPAGE = "https://pypi.org/project/importlib-metadata/"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=e88ae122f3925d8bde8319060f2ddb8e"
21
22 SRC_URI[md5sum] = "80d677d744995336c9c22d21a85ddeb8"
23 SRC_URI[sha256sum] = "aa18d7378b00b40847790e7c27e11673d7fed219354109d0e7b9e5b25dc3ad26"
24
25 DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
26
27 PYPI_PACKAGE = "importlib_metadata"
28
29 inherit pypi setuptools
30
31 S = "${WORKDIR}/importlib_metadata-${PV}"
32
33 RDEPENDS_${PN} += "\
34     ${PYTHON_PN}-zipp \
35     ${PYTHON_PN}-pathlib2 \
36     python-compression \
37     python-configparser \
38     python-contextlib2 \
39     python-pathlib2 \
40 "
41
42 BBCLASSEXTEND = "native nativesdk"