build_inf.sh: change the protocal for github repo
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-gunicorn_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "gunicorn 'Green Unicorn' is a WSGI HTTP Server for UNIX"
17 DESCRIPTION = "\
18 Gunicorn 'Green Unicorn' is a Python WSGI HTTP Server for UNIX. \
19 It's a pre-fork worker model ported from Ruby's Unicorn project. \
20 The Gunicorn server is broadly compatible with various web frameworks, \
21 simply implemented, light on server resource usage, and fairly speedy. \
22 "
23
24 LICENSE = "MIT"
25 LIC_FILES_CHKSUM = "file://LICENSE;md5=03ccc2b0215ca2a4b1e5f3c5483807f9"
26
27
28 SRCREV = "328e509260ae70de6c04c5ba885ee17960b3ced5"
29 PROTOCOL = "https"
30 BRANCH = "19.x"
31 S = "${WORKDIR}/git"
32 PV = "19.7.1+git${SRCPV}"
33
34 SRC_URI = "git://github.com/benoitc/gunicorn.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
35
36
37 DEPENDS += " python"
38 inherit setuptools distutils pkgconfig