65b2ffab6509e0b8c42b8d084f2f3b1801d9bf9e
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-gunicorn_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Gunicorn 'Green Unicorn' is a Python WSGI HTTP Server for UNIX. It's a pre-fork worker model ported from Ruby's Unicorn project. The Gunicorn server is broadly compatible with various web frameworks, simply implemented, light on server resource usage, and fairly speedy."
17
18 LICENSE = "MIT"
19 LIC_FILES_CHKSUM = "file://LICENSE;md5=f75f3fb94cdeab1d607e2adaa6077752"
20
21
22 SRCREV = "67949dc71c54e435e62c1fcedc2315a9098d54ea"
23 PROTOCOL = "https"
24 BRANCH = "19.x"
25 S = "${WORKDIR}/git"
26 PV = "19.10.0+git${SRCPV}"
27
28 SRC_URI = "git://github.com/benoitc/gunicorn.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
29
30
31 DEPENDS += " python"
32 inherit setuptools distutils pkgconfig