Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-gnocchiclient_7.0.4.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "python-gnocchiclient"
17 STABLE = "master"
18 PROTOCOL = "https"
19 BRANCH = "master"
20 SRCREV = "64814b9ace54e0151e9c28f4e57b87dafc984241"
21 S = "${WORKDIR}/git"
22 PV = "7.0.4"
23
24 LICENSE = "Apache-2.0"
25
26 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
27
28 SRC_URI = "git://github.com/gnocchixyz/python-gnocchiclient.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
29 DEPENDS += " \
30         python \
31         python-pbr-native \
32         "
33
34 RDEPENDS_${PN}_append = " python-ujson"
35
36 inherit setuptools