build_inf.sh: change the protocal for github repo
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-futurist_1.8.1.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Useful additions to futures, from the future"
17 HOMEPAGE = "https://pypi.python.org/pypi/futurist"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
21
22 SRC_URI[md5sum] = "3e5a4b8254ded1624ec807cb7ae04ba5"
23 SRC_URI[sha256sum] = "499ee57728a987028725f836ac22aa18899702162fa0a0f1bbe2ecd5c8daf1eb"
24
25 inherit setuptools pypi
26
27 DEPENDS += " \
28         python-pip \
29         python-pbr-native \
30         "
31
32 RDEPENDS_${PN} += " \
33         python-pbr \
34         python-six \
35         python-monotonic \
36         python-futures \
37         python-contextlib2 \
38         python-prettytable \
39         "
40