bf32c827b4c0c3c05b6ac666f91f09676cb8c6b5
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-eventlet_0.18.4.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Highly concurrent networking library"
17 HOMEPAGE = "http://pypi.python.org/pypi/eventlet"
18 SECTION = "devel/python"
19 LICENSE = "MIT"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=56472ad6de4caf50e05332a34b66e778"
21
22 SRC_URI[md5sum] = "8d1c646d8cc10a4958c92fe8a30f3676"
23 SRC_URI[sha256sum] = "74ef11d67ee5e85e009b0fced733c907620bca1ab8e6b0489d9f247405ab2685"
24
25 inherit setuptools pypi
26
27 RDEPENDS_${PN} += " \
28     python-enum34 \
29     python-enum-compat \
30     python-greenlet \
31     "