Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-django-horizon_15.1.0.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Simple database sharding (horizontal partitioning) library for Django applications."
17 HOMEPAGE = "http://horizon.openstack.org/"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
21
22 inherit setuptools 
23
24 SRC_URI[md5sum] = "21c32ba58806b351ede4eca6804e6d3e"
25 SRC_URI[sha256sum] = "25cf663f8f9a0233edbd5ba322acc28805fca684df28290c3e62a79abf6724e9"
26
27 S = "${WORKDIR}/horizon-${PV}"
28
29 SRC_URI = "https://tarballs.openstack.org/horizon/horizon-${PV}.tar.gz"
30
31 DEPENDS += " \
32         python-pip \
33         python-pbr-native \
34         "
35
36
37 RDEPENDS_${PN} = " \
38         python-pbr \
39         python-babel \
40         python-django \
41         python-django \
42         python-django-babel \
43         python-django-compressor \
44         python-django-debreach \
45         python-django-pyscss \
46         python-futurist \
47         python-iso8601 \
48         python-keystoneauth1 \
49         python-netaddr \
50         python-oslo.concurrency \
51         python-oslo.config \
52         python-oslo.i18n \
53         python-oslo.policy \
54         python-oslo.serialization \
55         python-oslo.upgradecheck \
56         python-oslo.utils \
57         python-osprofiler \
58         python-pint \
59         python-pymongo \
60         python-pyscss \
61         python-cinderclient \
62         python-glanceclient \
63         python-keystoneclient \
64         python-neutronclient \
65         python-novaclient \
66         python-swiftclient \
67         python-pytz \
68         python-pyyaml \
69         python-requests \
70         python-semantic-version \
71         python-six \
72         python-xstatic \
73         python-xstatic-angular \
74         python-xstatic-angular-bootstrap \
75         python-xstatic-angular-fileupload \
76         python-xstatic-angular-gettext \
77         python-xstatic-angular-lrdragndrop \
78         python-xstatic-angular-schema-form \
79         python-xstatic-bootstrap-datepicker \
80         python-xstatic-bootstrap-scss \
81         python-xstatic-bootswatch \
82         python-xstatic-d3 \
83         python-xstatic-hogan \
84         python-xstatic-font-awesome \
85         python-xstatic-jasmine \
86         python-xstatic-jquery \
87         python-xstatic-jquery-migrate \
88         python-xstatic-jquery.quicksearch \
89         python-xstatic-jquery.tablesorter \
90         python-xstatic-jquery-ui \
91         python-xstatic-jsencrypt \
92         python-xstatic-mdi \
93         python-xstatic-objectpath \
94         python-xstatic-mdi \
95         python-xstatic-objectpath \
96         python-xstatic-rickshaw \
97         python-xstatic-roboto-fontface \
98         python-xstatic-smart-table \
99         python-xstatic-spin \
100         python-xstatic-term.js \
101         python-xstatic-tv4 \
102         "