Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-django-debreach_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Simple database sharding (horizontal partitioning) library for Django applications."
17
18 LICENSE = "BSD"
19 LIC_FILES_CHKSUM = "file://LICENSE;md5=04c6b8f6ee56b21d30ecb172b066902c"
20
21
22 SRCREV = "b425bb719ea5de583fae7db5b7419e5fed569cb0"
23 PROTOCOL = "https"
24 BRANCH = "master"
25 S = "${WORKDIR}/git"
26
27 SRC_URI = "git://github.com/lpomfrey/django-debreach.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
28
29
30 DEPENDS += " python"
31 inherit setuptools distutils pkgconfig