Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-django-babel_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Tools for using Babel with Django"
17 HOMEPAGE = "https://github.com/python-babel/django-babel"
18 SECTION = "devel/python"
19 LICENSE = "BSD-3-Clause"
20 LIC_FILES_CHKSUM = "file://COPYING;md5=5ae97ab65116b8d7890c59de57577b46"
21
22 SRCREV = "1da5c0ba7ef3b12810154d9e64b3e847ecbb06cc"
23 SRCNAME = "django-babel"
24 BRANCH = "master"
25 PROTOCOL = "https"
26 PV = "0.6.2+git${SRCPV}"
27 S = "${WORKDIR}/git"
28
29 SRC_URI = "git://github.com/python-babel/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30         
31 inherit setuptools
32
33 DEPENDS += " python-pip"
34
35 RDEPENDS_${PN}_append = " \
36         python-django \
37         python-babel \
38         "
39