Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-cliff_2.14.1.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Command Line Interface Formulation Framework"
17 HOMEPAGE = "https://github.com/dreamhost/cliff"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
21
22 SRC_URI[md5sum] = "4c5d43d98970c79b091e25676cce2b10"
23 SRC_URI[sha256sum] = "b47387a344898ccb28ca7f386f017ade9eb66dc1713e5c642a0bc09ec606cc67"
24
25 inherit setuptools pypi
26
27 DEPENDS += "\
28     python-pbr \
29     "
30
31 # Satisfy setup.py 'setup_requires'
32 DEPENDS += " \
33     python-pbr-native \
34     "
35
36 RDEPENDS_${PN} += "python-prettytable \
37             python-cmd2 \
38             python-pbr \
39             python-pyparsing \
40             python-prettytable \
41             python-six \
42             python-stevedore \
43             python-unicodecsv \
44             python-pyyaml \
45 "
46
47 CLEANBROKEN = "1"