3d431d57a3a5a9c69cd53f946c7ffbf5e2cdf38a
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-cinderclient_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Client for the OpenStack Cinder API"
17 HOMEPAGE = "https://opendev.org/openstack/python-cinderclient"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=3572962e13e5e739b30b0864365e0795"
21
22 SRCREV = "4e17e1d1912f1902a37e4db543e38cdbe3961358"
23 SRCNAME = "python-cinderclient"
24 BRANCH = "stable/train"
25 PROTOCOL = "https"
26 PV = "4.1.0+git${SRCPV}"
27 S = "${WORKDIR}/git"
28
29 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31 inherit setuptools
32
33 DEPENDS += " \
34         python-pip \
35         python-pbr-native\
36         "
37
38 # Satisfy setup.py 'setup_requires'
39 DEPENDS += " \
40         python-pbr-native \
41         "
42
43 RDEPENDS_${PN} += " \
44         bash \
45         python-pbr \
46         python-prettytable \
47         python-keystoneauth1 \
48         python-oslo.i18n \
49         python-oslo.utils \
50         python-six \
51         python-osc-lib \
52         python-babel \
53         python-requests \
54         python-simplejson \
55         "
56
57
58 do_install_append() {
59         :
60 }
61
62 FILES_${PN} += " \
63         "