Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-cherrypy_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15 #
16
17 SUMMARY = " CherryPy is a pythonic, object-oriented HTTP framework"
18 DESCRIPTION = "\
19         It allows building web applications in much the same way one would build any other object-oriented program. \
20         This design results in less and more readable code being developed faster. It's all just properties and methods. \
21         It is now more than ten years old and has proven fast and very stable. \
22         It is being used in production by many sites, from the simplest to the most demanding. \
23         "
24
25
26 LICENSE = "BSD-3-Clause"
27 LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a8cbc5da4e6892b15a972a0b18622b2b"
28
29 SRCREV = "994803e4923e53b7079c79f4e9b502cc1b8d0aa6"
30 PROTOCOL = "https"
31 BRANCH = "master"
32 S = "${WORKDIR}/git"
33 PV = "18.2.0"
34
35 SRC_URI = "git://github.com/cherrypy/cherrypy.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
36
37
38 DEPENDS += " python python-setuptools-scm-native"
39 inherit setuptools distutils pkgconfig
40
41 RDEPENDS_${PN} += " \
42         python-compression \
43         python-crypt \
44         python-datetime \
45         python-email \
46         python-fcntl \
47         python-html \
48         python-io \
49         python-json \
50         python-logging \
51         python-netclient \
52         python-netserver \
53         python-profile \
54         python-pydoc \
55         python-xml \
56         python-unixadmin \
57         "
58         
59 RDEPENDS_${PN} += " \
60         python-cheroot \
61         python-contextlib2 \
62         python-memcached \
63         python-portend \
64         python-pyopenssl \
65         python-routes \
66         python-simplejson \
67         python-six \
68         python-zc-lockfile \
69         "