Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-castellan_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Generic Key Manager interface for OpenStack"
17 HOMEPAGE = "https://github.com/openstack/castellan"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
21
22 SRCREV = "8e2929b8779eaa03f15a25da5cf64ef8539a026b"
23 SRCNAME = "castellan"
24 PROTOCOL = "https"
25 BRANCH = "stable/stein"
26 S = "${WORKDIR}/git"
27 PV = "0.17.0+git${SRCPV}"
28
29 SRC_URI = "git://opendev.org/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30
31 inherit setuptools
32
33 DEPENDS += " \
34         python-pip \
35         python-pbr-native \
36         "
37
38 RDEPENDS_${PN} += " \
39         python-pbr \
40         python-babel \
41         python-cryptography \
42         python-barbicanclient \
43         python-oslo.config \
44         python-oslo.context \
45         python-oslo.i18n \
46         python-oslo.log \
47         python-oslo.utils \
48         python-keystoneauth1 \
49         "