Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-backports-init_1.0.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Helper package to avoid backports/__init__.py conflicts"
17 DETAIL = "backports packages in python2 suffer from a flaw in the namespace \
18 implementation and can conflict with each other. For OE purposes, at least \
19 fix the conflicting install of .../site-packages/backports/__init__.py"
20 AUTHOR = "Tim Orling <ticotimo@gmail.com>"
21 SECTION = "devel/python"
22
23 LICENSE = "MIT"
24 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
25
26 SRC_URI = "file://backports/__init__.py"
27
28 inherit python-dir
29
30 # provide to avoid warnings
31 do_compile() {
32     :
33 }
34
35 do_install() {
36     install -d ${D}${PYTHON_SITEPACKAGES_DIR}/backports
37     install ${WORKDIR}/backports/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/backports/
38 }
39
40 FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/backports/__init__.py"